Can’t use any of my legendaries or mhytics


Idk why but I can’t use any of my legendary or mhytic in online section. Can someone explain or give me a solution

1 Like

Cheater cheater pumpkin eater.

1 Like

What do you mean?
I’m not using any cheat :confused:
Can you please explain it in detail

1 Like

Can you show us what monsters you are trying to have in your team?

1 Like

Sure, wait a min I’m going to as it

1 Like


I can’t use any of them. After read some similar case, I think the reason is because I often switched device to play the account (?)
But I’m not cheating I swear, if there’s a way you can check it just check them.
Also I’ve already sent an email about 2 days ago concerning this problem

3 Likes

I have Leobolt too @Elmino

2 Likes

Thanks for sharing. Nothing stands out as odd. It’s probably from switching device, as you say. The game may be detecting them as monsters which it doesn’t think you’ve hatched, because it didn’t sync the hatching between the two devices. Unfortunately, the game is not made to be transferred between devices regularly so you can encounter problems like this.

Contacting support and getting them to fix it is the correct thing to do. However, you’ll also probably need to only play on one device from now on, only switching when you really need to.

1 Like

Understood. Thank you

It’s been one month already and the account hasn’t been fixed nor do I get a reply from the email. I dont even know where did I wrong tho it just feel really unfair

1 Like

Message @Dev_VKC here directly on the forum