Azrazel bugged in new patch

Prior to the patch a full hp zealous attack did 4-6k, depending on element. It’s now doing 2-3k. Is this intended, or a bug?

1 Like

What HP level was azrazel at? 50%?

All at 100%

Cant even kill cyclo @Dev_BRD @Dev_VKC dev @Killerdog

I noticed this in the test battle for this egg… definitely looks like the passive is no longer working. Has anyone tried Kamishogun and the mortar SE to see if it’s working there?

Don’t use him enough to know but 2 tests, 100% health:

Yeah that’s not working either by the looks of it. It should be like using an assisted move on a full attack monster with all monsters the same element (aka ~2.5k damage).

Just tested Azra and his passive is off, the only damage that surprised me was 4.9k of damage dealt to a Jaguardian at 100% hp. But it suppose to deal 6 to 7 k minimum to a Jaguardian.

Oh that’s why amradillo was super weak in the scb today

The first attack i did was weak, then hp was lowered below 50% and i healed it. Seems after the heal it was triggered. This is like drakos old passive which worked only in some occasions